Incident Notification - UI Slowness
Incident Report for Anodot Cost
Resolved
This incident has been resolved.
Posted Jan 09, 2024 - 12:57 UTC
Investigating
This is to inform you that we are experiencing an incident related to UI slowness in our system.
Our monitoring systems have detected increased response times, affecting the overall user experience.
Posted Jan 09, 2024 - 11:57 UTC
This incident affected: Generic Functionality (Cost Explorer, Dashboards & Reports, Users interface and API).