Delayed reporting on services in AWS invoices
Incident Report for Anodot Cost
Resolved
We finally received a confirmation from AWS that the issue was resolved. Below is the official AWS response:

Between March 21 at 11:01 AM and March 25 at 6:46 AM PDT, we experienced the issue of Cost Explorer and Cost and Usage Reporting (CUR) data delays in the Billing and Cost Management console. The issue has been resolved and the service is operating normally.
Posted Mar 25, 2024 - 20:06 UTC
Update
AWS CUR data is now up to date for all accounts, we are waiting for AWS to confirm that their incident is fully resolved.
Posted Mar 25, 2024 - 09:10 UTC
Update
Updating that although some customer's billing data latency should be fixed by now, the issue still exists in AWS systems so delays or partial information can still exists in all accounts.
AWS engineering will provide their next update on the issue state in 5-6 hours.
Posted Mar 24, 2024 - 19:27 UTC
Update
Based on AWS support the latency is a global issue they are actively working to solve, expecting progress by end of the day.
Posted Mar 24, 2024 - 09:43 UTC
Monitoring
AWS have informed us that due to internal delays in some of their major services (including EC2, RDS and others) there invoice data exported using CUR and processed by Anodot can be 2-3 days behind.
We'll update as soon as data processing delays will be back to normal.
Posted Mar 24, 2024 - 08:49 UTC
This incident affected: AWS Cloud Cost (AWS Invoices processing).