Invoices inaccuracy over June
Incident Report for Anodot Cost
Resolved
All data restored and no issue detected in the last 12 hours.
Posted Jun 16, 2023 - 15:14 UTC
Monitoring
Issue is now mitigated and invoice processing is back to normal, we'll continue monitoring for any abnormal behavior
Posted Jun 15, 2023 - 20:11 UTC
Identified
You may experience invoice inaccuracy over June timeframe in the format of duplicated invoice information, we are working to mitigate and restore the correct information. Data should be back to normal within 5 hours.

We'll update as soon as mitigation is completed.
Posted Jun 15, 2023 - 13:50 UTC
This incident affected: AWS Cloud Cost (AWS Invoices processing), GCP Cost (GCP Invoice processing), and Azure Cloud Cost (Azure Invoices processing).